# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\['"](*SKIP)(*FAIL)|["']//g;t' <<< "
#TEST string \"quoted part\\" witch escape\" other \"quoted string\"
"