#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\\['"](*SKIP)(*FAIL)|["']"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
" #TEST string "quoted part\" witch escape" other "quoted string"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)