use strict;
my $str = '
#TEST string "quoted part\\" witch escape" other "quoted string"
';
my $regex = qr/\\['"](*SKIP)(*FAIL)|["']/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";