$re = '/\\\\[\'"](*SKIP)(*FAIL)|["\']/';
$str = '
#TEST string "quoted part\\" witch escape" other "quoted string"
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;