import Foundation
let pattern = #"\\['"](*SKIP)(*FAIL)|["']"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
#TEST string "quoted part\" witch escape" other "quoted string"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)