using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\['""](*SKIP)(*FAIL)|[""']";
string substitution = @"";
string input = @"
#TEST string ""quoted part\"" witch escape"" other ""quoted string""
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}