re = /\\['"](*SKIP)(*FAIL)|["']/
str = '
#TEST string "quoted part\\" witch escape" other "quoted string"
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result