using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*_exact(?:_en|_ja)?$)(.+?)(_en|_ja)?$";
string substitution = @"$1_exact$2";
string input = @"something
something_en
something_ja
something_exact_en
something_exact";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}