import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*_exact(?:_en|_ja)?$)(.+?)(_en|_ja)?$";
final String string = "something\n"
+ "something_en\n"
+ "something_ja\n"
+ "something_exact_en\n"
+ "something_exact";
final String subst = "$1_exact$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}