$re = '/^(?!.*_exact(?:_en|_ja)?$)(.+?)(_en|_ja)?$/m';
$str = 'something
something_en
something_ja
something_exact_en
something_exact';
$subst = "$1_exact$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;