import Foundation
let pattern = #"^(?!.*_exact(?:_en|_ja)?$)(.+?)(_en|_ja)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
something
something_en
something_ja
something_exact_en
something_exact
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1_exact$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)