const regex = /^(?!.*_exact(?:_en|_ja)?$)(.+?)(_en|_ja)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*_exact(?:_en|_ja)?$)(.+?)(_en|_ja)?$', 'gm')
const str = `something
something_en
something_ja
something_exact_en
something_exact`;
const subst = `$1_exact$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);