import re
regex = re.compile(r"^(?!.*_exact(?:_en|_ja)?$)(.+?)(_en|_ja)?$", flags=re.MULTILINE)
test_str = ("something\n"
"something_en\n"
"something_ja\n"
"something_exact_en\n"
"something_exact")
subst = "$1_exact$2"
result = regex.sub(subst, test_str)
if result:
print(result)