re = /^(?!.*_exact(?:_en|_ja)?$)(.+?)(_en|_ja)?$/m
str = 'something
something_en
something_ja
something_exact_en
something_exact'
subst = '$1_exact$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result