#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{1,2})\s?\:\s?(\d{1,2})\s?\:\s?(\d{1,2})"
Local $sString = "06 : 11 : 33" & @CRLF & _
"" & @CRLF & _
"05:42:12" & @CRLF & _
"" & @CRLF & _
"12:00:01" & @CRLF & _
"" & @CRLF & _
"1 : 3 : 59" & @CRLF & _
"" & @CRLF & _
"01 : 03 : 59" & @CRLF & _
"" & @CRLF & _
"01:03:59" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")