import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{1,2})\\s?\\:\\s?(\\d{1,2})\\s?\\:\\s?(\\d{1,2})";
final String string = "06 : 11 : 33\n\n"
+ "05:42:12\n\n"
+ "12:00:01\n\n"
+ "1 : 3 : 59\n\n"
+ "01 : 03 : 59\n\n"
+ "01:03:59\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}