// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{1,2})\s?\:\s?(\d{1,2})\s?\:\s?(\d{1,2})").unwrap();
let string = "06 : 11 : 33
05:42:12
12:00:01
1 : 3 : 59
01 : 03 : 59
01:03:59
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}