import re
regex = re.compile(r"(\d{1,2})\s?\:\s?(\d{1,2})\s?\:\s?(\d{1,2})", flags=re.MULTILINE)
test_str = ("06 : 11 : 33\n\n"
"05:42:12\n\n"
"12:00:01\n\n"
"1 : 3 : 59\n\n"
"01 : 03 : 59\n\n"
"01:03:59\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")