const regex = /(\d{1,2})\s?\:\s?(\d{1,2})\s?\:\s?(\d{1,2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,2})\\s?\\:\\s?(\\d{1,2})\\s?\\:\\s?(\\d{1,2})', 'gm')
const str = `06 : 11 : 33
05:42:12
12:00:01
1 : 3 : 59
01 : 03 : 59
01:03:59
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}