$re = '/(\d{1,2})\s?\:\s?(\d{1,2})\s?\:\s?(\d{1,2})/m';
$str = '06 : 11 : 33
05:42:12
12:00:01
1 : 3 : 59
01 : 03 : 59
01:03:59
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);