package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{1,2})\s?\:\s?(\d{1,2})\s?\:\s?(\d{1,2})`)
var str = `06 : 11 : 33
05:42:12
12:00:01
1 : 3 : 59
01 : 03 : 59
01:03:59
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}