#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<br\s*\/?>\s*<br\s*\/?>"
Local $sString = "sad sa " & @CRLF & _
"asd " & @CRLF & _
"<br> <br> <br/>" & @CRLF & _
"asdsd" & @CRLF & _
"as" & @CRLF & _
"da" & @CRLF & _
"sd" & @CRLF & _
"" & @CRLF & _
"<br/>" & @CRLF & _
"<br/>" & @CRLF & _
"<br/>" & @CRLF & _
"" & @CRLF & _
"<br/> <br/> <br/> <br/> <br/><br/><br/><br/>" & @CRLF & _
"" & @CRLF & _
"<br/> <br/>" & @CRLF & _
"<br/><br/><br/>" & @CRLF & _
"" & @CRLF & _
"asg hfhgfhg" & @CRLF & _
"dsadsaddddddddddddddd fgh fgh fa" & @CRLF & _
"sd" & @CRLF & _
"sad" & @CRLF & _
"as" & @CRLF & _
"sdvfdbvdfbdf df fgh dgh g hgf" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")