// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<br\s*\/?>\s*<br\s*\/?>").unwrap();
let string = "sad sa
asd
<br> <br> <br/>
asdsd
as
da
sd
<br/>
<br/>
<br/>
<br/> <br/> <br/> <br/> <br/><br/><br/><br/>
<br/> <br/>
<br/><br/><br/>
asg hfhgfhg
dsadsaddddddddddddddd fgh fgh fa
sd
sad
as
sdvfdbvdfbdf df fgh dgh g hgf
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}