const regex = /<br\s*\/?>\s*<br\s*\/?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<br\\s*\\\/?>\\s*<br\\s*\\\/?>', 'gm')
const str = `sad sa
asd
<br> <br> <br/>
asdsd
as
da
sd
<br/>
<br/>
<br/>
<br/> <br/> <br/> <br/> <br/><br/><br/><br/>
<br/> <br/>
<br/><br/><br/>
asg hfhgfhg
dsadsaddddddddddddddd fgh fgh fa
sd
sad
as
sdvfdbvdfbdf df fgh dgh g hgf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}