re = /<br\s*\/?>\s*<br\s*\/?>/m
str = 'sad sa
asd
<br> <br> <br/>
asdsd
as
da
sd
<br/>
<br/>
<br/>
<br/> <br/> <br/> <br/> <br/><br/><br/><br/>
<br/> <br/>
<br/><br/><br/>
asg hfhgfhg
dsadsaddddddddddddddd fgh fgh fa
sd
sad
as
sdvfdbvdfbdf df fgh dgh g hgf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end