import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<br\\s*\\/?>\\s*<br\\s*\\/?>";
final String string = "sad sa \n"
+ "asd \n"
+ "<br> <br> <br/>\n"
+ "asdsd\n"
+ "as\n"
+ "da\n"
+ "sd\n\n"
+ "<br/>\n"
+ "<br/>\n"
+ "<br/>\n\n"
+ "<br/> <br/> <br/> <br/> <br/><br/><br/><br/>\n\n"
+ "<br/> <br/>\n"
+ "<br/><br/><br/>\n\n"
+ "asg hfhgfhg\n"
+ "dsadsaddddddddddddddd fgh fgh fa\n"
+ "sd\n"
+ "sad\n"
+ "as\n"
+ "sdvfdbvdfbdf df fgh dgh g hgf\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}