$re = '/<br\s*\/?>\s*<br\s*\/?>/m';
$str = 'sad sa
asd
<br> <br> <br/>
asdsd
as
da
sd
<br/>
<br/>
<br/>
<br/> <br/> <br/> <br/> <br/><br/><br/><br/>
<br/> <br/>
<br/><br/><br/>
asg hfhgfhg
dsadsaddddddddddddddd fgh fgh fa
sd
sad
as
sdvfdbvdfbdf df fgh dgh g hgf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);