# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/just the, \\#2EFHF7(\w+)\\#DF02A5/$1/gm;t' <<< "just the, \#2EFHF7word\#DF02A5"