import Foundation
let pattern = ##"just the, \\#2EFHF7(\w+)\\#DF02A5"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"just the, \#2EFHF7word\#DF02A5"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)