package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)just the, \\#2EFHF7(\w+)\\#DF02A5`)
var str = `just the, \#2EFHF7word\#DF02A5`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}