// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)just the, \\#2EFHF7(\w+)\\#DF02A5").unwrap();
let string = "just the, \\#2EFHF7word\\#DF02A5";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}