const regex = /just the, \\#2EFHF7(\w+)\\#DF02A5/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('just the, \\\\#2EFHF7(\\w+)\\\\#DF02A5', 'gm')
const str = `just the, \\#2EFHF7word\\#DF02A5`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);