use strict;
my $str = 'just the, \\#2EFHF7word\\#DF02A5';
my $regex = qr/just the, \\#2EFHF7(\w+)\\#DF02A5/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";