re = /just the, \\#2EFHF7(\w+)\\#DF02A5/m
str = 'just the, \\#2EFHF7word\\#DF02A5'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result