package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(слово1.*слово2)|(слово2.*слово1)(?-i)`)
var str = `Слово2 и Слово1.
Слово1 и Слово2.
Слово1.
Слово2, а также слово1.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}