re = /(?i)(слово1.*слово2)|(слово2.*слово1)(?-i)/m
str = 'Слово2 и Слово1.
Слово1 и Слово2.
Слово1.
Слово2, а также слово1.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end