const regex = new RegExp('(?i)(слово1.*слово2)|(слово2.*слово1)(?-i)', 'gm')
const str = `Слово2 и Слово1.
Слово1 и Слово2.
Слово1.
Слово2, а также слово1.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}