// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)(слово1.*слово2)|(слово2.*слово1)(?-i)").unwrap();
let string = "Слово2 и Слово1.
Слово1 и Слово2.
Слово1.
Слово2, а также слово1.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}