import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(слово1.*слово2)|(слово2.*слово1)(?-i)";
final String string = "Слово2 и Слово1.\n"
+ "Слово1 и Слово2.\n"
+ "Слово1.\n"
+ "Слово2, а также слово1.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}