# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/a+|\d+/x/gm;t' <<< "123,456,789
123,456,a,789
aaa,aa,aaa
aa,123,456,aaaa,789
aaa,123,456,aa,789,aaaa"