# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"a+|\d+"
test_str = ("123,456,789\n"
"123,456,a,789\n"
"aaa,aa,aaa\n"
"aa,123,456,aaaa,789\n"
"aaa,123,456,aa,789,aaaa")
subst = "x"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.