// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)a+|\d+").unwrap();
let string = "123,456,789
123,456,a,789
aaa,aa,aaa
aa,123,456,aaaa,789
aaa,123,456,aa,789,aaaa";
let substitution = "x";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}