re = /a+|\d+/m
str = '123,456,789
123,456,a,789
aaa,aa,aaa
aa,123,456,aaaa,789
aaa,123,456,aa,789,aaaa'
subst = 'x'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result