const regex = /a+|\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('a+|\\d+', 'gm')
const str = `123,456,789
123,456,a,789
aaa,aa,aaa
aa,123,456,aaaa,789
aaa,123,456,aa,789,aaaa`;
const subst = `x`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);