#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)a+|\d+"
Local $sString = "123,456,789" & @CRLF & _
"123,456,a,789" & @CRLF & _
"aaa,aa,aaa" & @CRLF & _
"aa,123,456,aaaa,789" & @CRLF & _
"aaa,123,456,aa,789,aaaa"
Local $sSubst = "x"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)