$re = '/a+|\d+/m';
$str = '123,456,789
123,456,a,789
aaa,aa,aaa
aa,123,456,aaaa,789
aaa,123,456,aa,789,aaaa';
$subst = "x";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;