using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"decided\s+by\s+(?P<presiding_judge>[A-Za-z]+)\s*,\s+Presiding\s+Judge;\s+(?P<judge>[A-Za-z]+)\s*,\s+Judge;\s+and\s+(?P<extra_jusdges>[A-Za-z,\s]+)\s*,\s+Judge\.?";
string input = @"Considered and decided by Hemingway, Presiding Judge; Bell,
Judge; and
Dickinson, Emily, Judge
Considered and decided by Einstein, Presiding Judge; Abel,
Judge; and
Lagrange, Gauss, Judge
Considered and decided by Newton, Presiding Judge; Dirichlet,
Judge; and
Fourier, Cauchy, Judge";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}