import re
regex = re.compile(r'decided\s+by\s+(?P<presiding_judge>[A-Za-z]+)\s*,\s+Presiding\s+Judge;\s+(?P<judge>[A-Za-z]+)\s*,\s+Judge;\s+and\s+(?P<extra_jusdges>[A-Za-z,\s]+)\s*,\s+Judge\.?', flags=re.MULTILINE | re.DOTALL)
test_str = ("Considered and decided by Hemingway, Presiding Judge; Bell, \n"
"Judge; and\n\n"
"Dickinson, Emily, Judge\n"
"Considered and decided by Einstein, Presiding Judge; Abel, \n"
"Judge; and\n\n\n"
"Lagrange, Gauss, Judge\n"
"Considered and decided by Newton, Presiding Judge; Dirichlet, \n"
"Judge; and\n\n\n"
"Fourier, Cauchy, Judge")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")