use strict;
my $str = 'Considered and decided by Hemingway, Presiding Judge; Bell,
Judge; and
Dickinson, Emily, Judge
Considered and decided by Einstein, Presiding Judge; Abel,
Judge; and
Lagrange, Gauss, Judge
Considered and decided by Newton, Presiding Judge; Dirichlet,
Judge; and
Fourier, Cauchy, Judge';
my $regex = qr/decided\s+by\s+(?P<presiding_judge>[A-Za-z]+)\s*,\s+Presiding\s+Judge;\s+(?P<judge>[A-Za-z]+)\s*,\s+Judge;\s+and\s+(?P<extra_jusdges>[A-Za-z,\s]+)\s*,\s+Judge\.?/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}