import Foundation
let pattern = #"decided\s+by\s+(?P<presiding_judge>[A-Za-z]+)\s*,\s+Presiding\s+Judge;\s+(?P<judge>[A-Za-z]+)\s*,\s+Judge;\s+and\s+(?P<extra_jusdges>[A-Za-z,\s]+)\s*,\s+Judge\.?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Considered and decided by Hemingway, Presiding Judge; Bell,
Judge; and
Dickinson, Emily, Judge
Considered and decided by Einstein, Presiding Judge; Abel,
Judge; and
Lagrange, Gauss, Judge
Considered and decided by Newton, Presiding Judge; Dirichlet,
Judge; and
Fourier, Cauchy, Judge
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)